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Introduction

Welcome to the HP 53305A Phase Analyzer Demonstration Software!
This demonstration gives you an opportunity to use the analyzer just
as you would in a measurement application. You will recall data files
of actual measurements saved to a disk using the HP 53305A Phase
Analyzer Software with the HP 53310A Modulation Domain Analyzer
(MDA) as the measurement hardware.

This Demonstration Guide shows you how the HP 53305A Phase
Analyzer Software and the HP 53310A Modulation Domain Analyzer
can be configured to make frequency and phase measurements on
various RF components in your communications design. Examples
include measuring frequency and phase settling times of VCOs and
PLLs, measuring the total integrated noise power over the modulation
bandwidth, examining the phase deviation (phase trajectory) of the
RF transmission, and looking at phase modulation frequencies and
spurs.

It is recommended that you do all the demonstrations described in
this guide to see the full set of capabilities the HP 53305A provides.
The demonstrations are best done in order, as subsequent
demonstrations build on points made earlier. The entire
demonstration should take approximately 20 to 30 minutes to
complete.




Phase Analyzer Product Description

The HP 53310A Modulation Domain Analyzer’s Option 305 Phase
Analysis Software adds the power of phase analysis in the Modulation
Domain to your HP 53310A MDA. The software is a Microsoft®
Windows-based program that runs on an IBM compatible PC. If you
already own the HP 53310A MDA, the software is available
separately as the HP 53305A. Now you can better understand your
design through direct phase analysis by measuring phase settling
time, phase noise (phase spectrum, total integrated noise power over
the modulation bandwidth), and phase deviation (phase trajectory).

External downconversion and uncalibrated discriminators are a thing
of the past. With the software and the HP 53310A MDA Option 031
High Resolution 2.5 GHz Input, you can directly measure the phase
detector’s RF output at modulation rates up to 500 kHz, saving you
time and effort.

Up to 8,000 continuous samples of frequency or phase (up to a 1-MHz
sample rate) can be stored and analyzed with the standard memory.
Up to 32,000 samples are available with the HP 53310A MDA Option
001 Extended Memory.

The program uses pull-down menus and buttons like many other
Windows applications to accomplish tasks. The primary task is to
display data gathered by the HP 53310A MDA hardware in a format
you have never been able to see with just the HP 53310A MDA alone,
such as phase settling time. Measurement results, graphs and data
can be easily exported to other Windows applications using the
Clipboard or files.

The HP 53305A software offers the following functionality:

Frequency

Frequency deviation (deviation from carrier)

Phase Deviation (phase trajectory)

Phase Power Spectral Density (total integrated noise in the

modulation bandwidth)

e FFT of current display (frequency or phase modulation
spectrum)

¢ Histogram of current display (peak-to-peak and rms
modulation)

e Automatic settling time (VCO or PLL)




System Requirements

The minimum PC system requirements to use this demonstration
software are:

386-based microprocessor with a 387 math coprocessor.

4 Mbyte RAM.

2 Mbyte free hard disk space.

VGA Display, keyboard and a two-button mouse.
MS-DOS 5.0.

Windows 3.1.

3.5-inch floppy disk drive.




NOTE

Loading the Demonstration Software
Installation of the demonstration software takes about 5 minutes.

Insert the HP 53305A demonstration diskette into the 3.5-inch floppy
drive.

Start Windows.

Open the Program Manager window and choose Run from the File
menu.

Type a:\setup and then press ENTER or click the OK button.

If your 3.5-inch drive is not assigned to a:, then substitute the correct
drive assignment in place of a:.

The software cannot be installed while another Visual Basic program is
open in Windows. If you see an error message to this effect, close all
other Visual Basic programs to proceed with the installation.

Sometime after pressing ENTER, you will see the installation window
shown below. This window allows you to modify the directory for the
software installation, or to cancel the installation completely. To
cancel the installation, click the Exit Setup key or press ALT E.

HP 53305A Setup

If you want to install the test application in a different directory
and/or diive. type the name of the directory.

[T R C: \HP53305A]

To quit Setup. choose the Exit button.




To Modify the Directory

The default directory is c¢:\hp53305a. If you want to install the
demonstration software files in a different directory, highlight
hp53305a and type in the preferred directory name. Highlight the
C:\ if you wish to modify the drive location as well. Click the
Continue button to continue the installation.

A new program group “HP Applications” will be created with this
installation. The HP 53305A demonstration application and a
“readme” file will be placed in this program group.

An Interface Options window will appear next. Choose “none” and
click the OK button.

When the installation is complete, click the OK button or press
ENTER.

The installation procedure will present a registration information
reminder which may be ignored with this demonstration software.
You are welcome to share this demonstration software with others
and copy it freely.

Double-click the HP 53305A icon to open the application and begin
the demonstration. You will see a message indicating that this is a
demonstration version of the HP 53305A software.




Demonstrations With Saved Data

The demonstrations use data that was acquired with the HP 53310A
MDA and processed using the HP 53305A software. The acquired
data was saved in files in the “demo” directory.

You will be recalling this measurement data from stored files that are
installed during the HP 53305A demonstration software installation
process described earlier. These demonstrations can be performed
without having the HP 53310A Modulation Domain Analyzer
hardware present.

Three demonstrations are included to show you the functionality and
power of the HP 53305A Phase Analyzer Software.

Demo 1 shows the step response of a VCO (voltage controlled
oscillator). This demonstration introduces you to some basic features
of the software; for example, saving and recalling data files, zooming
and scaling, and making settling time measurements.

Demo 2 shows the phase modulation analysis capabilities using a
BPSK signal (binary phase shift keying). This is a common form of
intentional phase modulation for digital communication systems,
where a carrier is shifted between two phase states (+ 180 degrees).

Demo 3 shows how you can export the graphics and the results of the
analyses to other Windows programs.




Demo 1:

Voltage-Controlled Oscillator (VCO) Step
Response and Settling Time

This demonstration shows a VCO whose output is stepped from

9 MHz to 10 MHz. Data was saved to a file, along with the
measurement setup which processes the data for frequency and phase
measurements. The following will be demonstrated:

Recalling data files from disk
Frequency measurements

Using the cursors

Zooming and scaling

Frequency deviation measurements
Frequency overshoot

Frequency settling time

Phase deviation measurements
Phase settling time

Overview

The VCO under test has a voltage step applied to the input control
voltage causing the frequency output to step from 9 MHz to 10 MHz.
A trigger signal occurs approximately 116 psec prior to the voltage
step. This trigger signal is connected to the “Ext Arm” input of the
HP 53310A. The VCO output signal is connected to input A of the
HP 533104, and is 1 volt pk-pk, centered at 0 volts (no DC offset).

10 MHz

Frequenc
e Y / VCO output
9 MHz

1V

116 usec |

Voltage

VCO voltage step command
ov

5V
Voltage

_ Trigger signal
ov
Time

1 Select File>Load Setup.

Select the file veo.stp in the c:\hp53305a\demo directory.




This retrieves the instrument setups used to capture the signal. They
will be examined in detail after viewing the Frequency vs. Time
display.

Select File>Load Data File.
Select the file veo.pan in the e:\hp53305a\demo directory.

This will retrieve the data and display the computed frequency versus
time.

Frequency Measurements
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This is a display of frequency versus time.

The step response, frequency overshoot, and settling can be seen
clearly on this display. They will be examined in more detail later in
this procedure.

Cursors

The software lets you easily find the (x,y) coordinates of any point on
the display (it doesn’t have to be a measurement point.) Position the

“crosshair” (+) using the mouse at a point of interest, for example the
peak of the VCO step waveform, and click the left mouse button. The

¢



bottom entry in the log area (bottom of the display) will show both the
x value (time) and the y value (frequency).

Move the cursor to a point at the bottom of the “ringing” of the
waveform and click the right mouse button. The data log now shows
the difference in both x (Dtime) and y (Dfreq) from the previous
cursor position (D = delta). The peak-to-peak ringing is about

130 kHz. You can continue positioning the cursor at various points
and clicking the right mouse button; each new log entry will be the x,y
difference from the previous cursor position.

Zooming

Any portion of the data display may be arbitrarily magnified using
the zoom feature. You simply define two diagonal corners of a
rectangle which will be the new, magnified display.

To magnify the peak overshoot and settling of the VCO response,
position the cursor just to the left of the overshoot of the waveform
and click the left mouse button. You've just defined the upper left
hand corner position of the magnified display.

Next move the cursor to a point just to the right of the ringing portion
of the waveform, and slightly beneath the 10 MHz frequency level.
Click the left mouse button again and you have defined the lower
right hand corner position of the magnified display.




3 Click.the Zoom button on the tool bar.
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The display “zooms” to the points defined by the previous two cursor
positions.

NOTE Valid cursor positions include any portion of the display where the cursor
appears as a crosshair (+). The data area is not confined to the grid
portion of the display. You can actually increase the current display range

by clicking in positions off of the grid.

4 To return the scaling to the previous full view, click the FULL button.
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Setups
1 Select Setup>Instrument Setup.

HP 53310A Setup

r Input [ Arming
Configure: Threshold: -10.24V 0 10.24 ¥
- X use External Arm

[0.000 ¥ |
Q Gnd

[1%10 Probe Oect  Oxio
Hysteresis: @® TTL

Select Measurement Channel

on Measure/View Setup Menu
] Delay from Arm

Coupling Impedance
@ AC @ 50 Ohm [0.0000 s
Obc O 1 MOhm 0.0000 s to 1.0000 s

[ Channel C Setup

® Prescale
Q Down Convert

@ intomat 10
O £xtemat 1.0

This is the Instrument Setup dialog box for the HP 533104,
configured to measure the VCO signal. The input circuitry for inputs
A, B, and C and the Ext Arm input, as well as the delay from Ext Arm
are specified on this dialog box. If Option 031 Channel C is not
present, the Channel C setup section cannot be accessed.

2 Click Cancel to close this dialog box without making changes, and
proceed to the next step.
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3 Select Setup>Measure/View Setup.

I Measure/View Setu I

Number of Samples: 1024
Measurement Time: 1.0240 ms
Number of Averages: 1

(] Disable Pre-measure

Calculated using Least Squares Fit

|

The Measure/View Setup dialog box lets you set various parameters
that apply to the computations performed on the raw timing
information from the measurement hardware. You can see the various
choices of parameters for Frequency & Phase measurement
processing. In this case 1,024 measurement samples will be acquired
over a period of 1.024 ms. Note that this implies a sample interval of 1
psec (1.024 msec/1,024 samples).

The remainder of this dialog box is left with default values for this
measurement. No filtering will be applied to the data. The carrier
frequency will be calculated automatically from the data using a
least-square fit algorithm. For the VCO, the “carrier” frequency is
not steady-state or repetitive modulation (it switches from 9 MHz

to 10 MHz, with most of the time spent at the final value of 10 MHz).
So an “average” carrier value of slightly less than 10 MHz results.
The carrier frequency will be used later in the procedure to determine
the deviation of the signal from the carrier value. Pacing will be
determined automatically, and input A will be used for acquiring
data.
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Frequency Deviation Measurements

For this measurement it is advantageous to view frequency in terms
of deviation from a carrier. This can make it easier to see the peak-to-
peak deviation on a steady-state or modulated carrier. For the VCO, a
frequency deviation display shows the ringing and overshoot (the
deviation from the final 10 MHz “carrier”) at a glance, with more
resolution than the frequency display (e.g., you can see kHz deviation
directly). You can measure signals directly as frequency deviation. Or,
since the VCO data has been recalled from disk, you can view the
original frequency data as frequency deviation without taking a new
measurement.

To change the carrier frequency value to 10 MHz, select “User
Specified” in the Clock/Carrier Frequency area of the dialog box,
enter 10 M (10 MHz) and press ENTER.

Click the OK button to close the window.

Select View>Frequency Deviation.

HP 533054 Frequency Deviation versus time (file=vco.pan)
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The display will be updated with calculations based on the new
carrier of 10 MHz. The carrier shows up in the display as a green line
with a value of zero. The absolute value of the carrier is displayed at
the bottom of the screen as Fo. If it is not displayed, click the Fo
button. Note that it is much easier to see the overshoot directly from
the display, without having to use the cursors.

NOTE

The display does not update the new Fo value until View>Frequency
Deviation is executed.

Autoscale and Scaling

The HP 53305A will normally autoscale to the current data set,
placing the minimum value near the bottom of the display, and the
maximum value near the top of the display. This is particularly useful
when you don’t know the exact values of the acquired data.

At other times you may be interested in manually fixing the scale to
view a particular portion of the waveform. For example, you may only
be interested in the waveform settling characteristics. Suppose that
you are only interested in verifying that the VCO output frequency is
within + 10 kHz of 10 MHz, 225 psec after the Ext Arm signal occurs.

1 To fix the display scale in that region, select Setup>Display Setup.

CO Frequency Step [03-07-1994)

0.0000 kHz

-10.0000 kHz

Get Autoscale Value

2 Click the Autoscale Always box to disable this feature.
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Enter 10 k into the Max Frequency Deviation field and press
ENTER.

Enter —10 k into the Min Frequency Deviation field and press
ENTER.

Enter 225 u (for psec) and 325 u into the Min Time and Max Time
fields respectively. Press ENTER after each entry.

Click OK to close this window.

HP53305A Frequency Deviation versus time [file=vco.pan)
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The display scale is now fixed at these values. This VCO fails the
+ 10 kHz after 225 nsec specification since the frequency first enters
the display window at about 230 psec.

Automatic Frequency Settling Time

You can also have the HP 53305A software calculate the settling time
of the VCO for you automatically, without using the Setup>Display
Setup dialog box.

Return to the original display by clicking on the Autoscale button.

To set the settling time parameters, select Setup>Settling Time
Setup.
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In the Frequency Deviation Settling Time Parameters area, .\j\
check the “Use final value as target value” box if it is not checked ‘
already.

Enter 10 k in the “Allowed deviation from target value” text box and
press ENTER.

Click OK to close this window.

Click the Settle Time button.
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The VCO settling time (230.7 psec) is calculated for you automatically
and displayed in the data display at the bottom of the screen.
Horizontal markers show the tolerance band of 10 kHz and vertical
markers show the time that the VCO first settles within the tolerance
band (the settling time).

You can zoom in on the display to see more detail. Click the Settle
Time button after you zoom in to display the markers again.

Phase Deviation Measurements

You can use a similar procedure to examine the phase settling time of
PLLs. In this case, we will examine the phase of the VCO as it settles
to the final 10 MHz frequency value.
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1 Select View>Phase Deviation.

HP 533054 Phase Deviation versus time [file=vco.pan)
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The phase deviation display shows the difference between the phase
of the measured signal to an unmodulated, perfect carrier of 10 Mhz.

NOTE

The “perfect” carrier is entered into the software in one of 3 ways.

1.

Enter a “user specified” carrier frequency in the Clock/Carrier
Frequency portion of the Setup>Measure/View Setup dialog box as
you did earlier in the Frequency Deviation Measurements part of this
VCO demonstration.

Select “calculated” instead of “user specified” and the software will
calculate an “average” frequency from the measured data (using the
Carrier Estimator Type selected).

Use the DeTilt process described in the next demonstration. You
may need to use DeTilt and Zoom several times to fine tune the
carrier frequency.

Since the VCO is switching between 9 MHz and 10 Mhz at the start of
the measurement, the phase is at first very far away from the phase
of a 10 MHz carrier. But as the VCO settles around 10 MHz, there is
very little deviation from the final value. The final value of phase is
arbitrary.
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If you wish to view the display with phase units other than degrees,
select Setup>Phase Units and select radians or unit interval.
Return the Phase Units to degrees when done.

Automatic Phase Settling Time

To set the settling time parameters, select Setup>Settling Time
Setup.

In the Phase Deviation Settling Time Parameters area, check the
“Use final value as target value” box if it is not checked already.

Enter 90 in the “Allowed deviation from target value” text box and
press ENTER. The phase units you are currently using will be
appended to this value (degrees in this case).

Click OK to close this window.

Click the Settle Time button.

HP 533054 Phase Deviation versus time [file=vce.pan)
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The phase settling time (204.6 psec) is calculated for you
automatically and displayed in the data display at the bottom of the
screen. Horizontal markers show the tolerance band of 90 degrees and
vertical markers show the time that the phase of the VCO first settles

within the tolerance band (the settling time).

You can zoom in on the display to see more detail. Click the Settle
Time button after you zoom in to display the markers again.

Select File>Load Default Setup to return the software to the
default setup conditions.

This completes Demo 1.
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Demo 2:

Phase Modulation Analysis (BPSK)

This demonstration shows the phase modulation analysis capabilities
of the MDA, using a BPSK signal (binary phase shift keying). This is
a common form of intentional phase modulation for digital
communication systems, where a carrier is shifted between two phase
states (x 180 degrees). A “1” may be represented by one of the phase
states, while a “0” is represented by the other.

The HP 53310A is used to gather timing information from the
modulated carrier. This information has been processed as deviation
in phase from a carrier and stored in a file. The following features will
be demonstrated on this waveform:

¢ Phase Deviation measurements
o De-Tilt feature
o FFT analysis

Overview

The signal is a 100 kHz carrier, phase modulated by a 1 kHz square
wave. The input signal has an amplitude of 500 mV p-p, and is
centered about 0 volts. The signal is connected to input A of the

HP 53310A.

Select File>Load Setup.
Select the file bpsk.stp in the c:\hp53305a\demo directory.

This retrieves the instrument setups used to capture the signal. They
will be examined in detail before viewing the Phase Deviation vs.
Time display.

Select File>Load Data File.
Select the file bpsk.pan in the ¢:\hp53305a\demo directory.

This will retrieve the data and display the computed phase deviation
versus time.

20
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Setups
1 Select Setup>Instrument Setup.

HP 53310A Setup

[ input - Arming
Configure: Thieshold: 1024V 10 10.24V | | -\ |
©Tﬁ ﬁunnv J Use External Arm
Q8 O ® 6nd
X10 Prob
oc e Q et O xts

Ecy Hysteresis: O 1L

I Stepe
@ +
Select Measurement Channel O -

on Measure/View Setup Menu
[ petay trom Arm

Coupling {mpedance [ ]
{@ AC —l [@ 50 Ohm _‘ (100.00 ns H

Ooc O 1 MOhm 0.0000 s to 1.0000 s

[ Channel £ Setup

O frescate K Aute Select LO Frequency

® Down Conver LO Frequency:

@ tntemat L0 (0.000000000 Hz il
Must be lower than input frequency.

O £xremnal 1O

——————

This is the HP 53310A Setup dialog box to configure the instrument
to measure the BPSK signal.

9 Click the Cancel button to exit this dialog box without making
changes.
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3 Select Setup>Measure/View Setup.

00.0000000000 kHz

Notice that the measurement time for the Frequency & Phase
function is 10.24 msec. This has been done so the display will show a
number of cycles of the 1 kHz modulation. The use of automatic
pacing will let the MDA determine the appropriate number of cycles
of the 100 kHz carrier to skip, so 10 msec of the signal can be
captured and analyzed. 10.24 msec/1024 samples implies that a
sample will be captured every 10 usec.

The Carrier Frequency has been entered as a User Specified value of
100.0 kHz. The phase deviation measurements will be computed
relative to the constant carrier frequency value of 100 kHz.

4 Click the Cancel button to exit this dialog box without making any
changes.
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Phase Deviation Measurements
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Zoom] [Full] | Fo ] | DeTilt { | integsat Slals.IAuloscdeI E:nb'l‘:ﬁ . |(:ls Hist Iﬂeﬂemuxel
hase devialion in degrees as function of time. Fs=1.001E+5Hz : Fo=1.0000000E +5Hz : 03/15/1 994.
PSK Signal (03-07-1994)
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Reading from C:\HP53305A\DEMO\BPSK.PAN k4
Finished reading from C:\HP53305A\DEMO\BPSK.PAN
Fo=100.0000080000 kHz Pace =1 N = 1024
Warning: Displayed graph may not reflect t setup p ters! Use View Menu to redisplay data.

This is a display of phase deviation from the constant carrier
frequency, Fo = 100 kHz. The square wave modulation can easily be
seen. Using the cursor and delta cursor feature (right mouse button),
you can easily determine the period of the modulation (about

980 psec), and the pk-pk values (about 180 degrees).

DeTilt

Notice that the display has a “tilt” over time. This is because the
actual carrier is not exactly 100.0 kHz as we specified as the carrier
frequency on the Measure/View Setup dialog box. The DeTilt
feature provides a convenient way to fine tune this value of Fo to get a
“flat” display, and determine the precise value of the actual carrier
frequency.

1 Position the cursor on one of the “high” phase states near the left side
of the plot (point A on the plot shown above). Click the left mouse
button.

2 Re-position the cursor on another “high” phase state near the right
side of the plot (point B on the plot shown). Click the left mouse
button.
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You have now defined two points which should be at the same vertical »*
level, but currently are not due to the “tilt” in the waveform.

Click the DeTilt button. A warning message will appear indicating
that the value of Fo will be modified in the DeTilt process. Click OK
to acknowledge the warning. After a moment of recalculation, the
graph will be re-drawn with a slightly modified value of Fo. The tilt
should be removed. Click the Fo button. Note the new value of Fo
(versus 100.0 kHz previously). You can view Fo in the results log at
the bottom of the display.

| HP 53305A Phase Deviation versus time ([file=bpsk.pan) #_
File Edit Setup Measure Yiew Help/Notes
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‘Warning: Displayed graph may not reflect current setup parameterst Use View Menu to redisplay data. +

Time= 1.216 msec; Phase= 1.326 1ad; 75.96 degree: 211.0mUI: 2.110 usec
Time= 9.244 msec: Phase= 1.852 sad: 106.1 degree; 294.7 mUl: 2.947 usec
Fo=100.0104261255 kHz Pace =1 N = 1024 ry

NOTE

The actual carrier frequency is about 10 Hz greater than the initial value
specified for Fo. The DeTilt feature lets you quickly correct for minor
discrepancies in Fo.

FFT Analysis

In certain applications it may be useful to study the spectrum of the
modulating tone, or perhaps the spectrum of undesired jitter. This
analysis can be useful to determine the source of unwanted jitter, or
phase noise.

The analysis software offers two methods to view jitter spectrum or
phase noise. FFT computations can be made on the currently
displayed data (vs. time views). Phase power spectral density
calculations can also be performed. This differs from the FFT
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calculations can also be performed. This differs from the FFT
calculations in that you may also specify a windowing type and
sample frequency for the calculations (Setup>Measure/View
Setup). The theoretical noise floor of the instrument is displayed in
addition to the measurement data.

1 Select View>FFT of current display.

= HP 533054 ffile=bpsk.pan) HEE
File Edit Setup Measure VYiew Help/Notes

Zoom | | Full Iiﬁ;il rl)efi!t I llnlegml’ ms ISta(cl IAulo:calel |St:l8e T'mxel |E3; }(iﬂi [Be&(ea&me ’
Mag{FFT)/N in dB. N=1024; Gaussian window: 09715/1934.
PSK Signal [(03-07-1994)

50.00
dB

10.00
dB/Div

ceepmaaqan=

Time= 1.216 msec; Phase= 1.326 rad: 75.96 degree: 211.0mUl: 2.110 usec
Time= 9.244 msec; Phase= 1.852 rad; 106.1 degree; 294.7 mUl: 2.947 usec
Fo=100.0104261255 kHz Pace =1 N = 1024

Fo=100.0104261255 kHz Pace =1 N = 1024 >

Using the cursor and clicking on each peak in the spectrum, the
characteristic odd harmonics of the square wave phase modulation
can be seen. Note that this is not the same view as a spectrum
analyzer would display (spectrum of the modulated carrier), but a
direct view of the spectral content of the modulation.

2 Select View>Phase Power Spectral Density.
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HP 533054 Phase Power Spectral Density {file=bpsk.pan])
File Edit Setup Measure View Help/Notes
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=1024.Gaussian window; Avg=1: Noise BW=193.1 Hz:Fs=100.1 kH2F0=100.0 kHz; 09/15/1994.
PSK Signal {03-07-1994)
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Computing.
Plotting.
Fo=100.0104261255 kHz Pace =1 N = 1024

Freqe6.997 kHz: Maglfft)/N = 18.00dB: E

This plot is very similar to the FFT. Note that the top line of the
display offers additional information, including the type of window
used in the computations, and the noise bandwidth. The solid line
across the bottom of the display (first decade up from the bottom)
indicates the noise floor of the HP 53310A. It may not be visible on
your display. If you wish to see it, you can fix the display scale by
using the Setup>Display Setup dialog box and entering —-150 as the
Min dB parameter.

Select File>Load Default Setup to return the software to the
default setup conditions.

This completes Demo 2.
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Demo 3:

Sharing MDA Graphs and Data

A powerful feature of Microsoft Windows is the ability to share data
and graphics between various applications using “cut and paste” or
files. The HP 53305A takes advantage of this feature allowing you to
easily share MDA data and graphics with other applications such as
spreadsheets (Lotus, Excel, etc.), word processors, and other
computational packages such as MathCad.

This demonstration will show how easy it is to share the HP 53305A
graphics plots and data with a word processor, such as the Windows
“Write” application. (In fact, this demonstration guide was written
using Microsoft Word for Windows, and illustrated with the

HP 53305A graphics using the cut and paste procedure).

Sharing Graphics
Select File>Load Data File.

Select the file fm.pan in the ¢:\hp53305a\demo directory.

You have retrieved a frequency modulated signal. Suppose you want
to integrate this data with a report or your lab notebook.

Select Edit>Copy Graph.

You have now copied the active window in the HP 53305A application
to the Windows Clipboard. If you want, you can verify the current
contents of the clipboard by opening the Clipboard Viewer application
in the Main group of Program Manager.
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Pasting Graphics into a Word Processor

Minimize the MDA application by clicking on the down arrow in the
top right corner of the window.

Double-click the Aceessories icon in the Program Manager display.
Double-click the Write icon to open this application.

You have now opened the Windows’ Write word processor application,
and you will see a blank space.

Select Edit>Paste.

=, Write - [Untitled) ME
File Edit Find Character Paragraph Document Help

Frequency deviation from Fo as function of time. F3=9.901E+5Hz : Fo=1. 0C0E +8Hz ; 09/15/1994.
Frequency Modulation {03-07-1994)

256
kHz

52.2
kHz/div |

103 usec/div

You have just copied the bit mapped graphics from the MDA
application to the word processor. No scope cameras, and no printers
or plotters to worry about.

Copying and Pasting Log Text

Double-click the HP 53305A icon (or select it from the Window pull-
down in the Program Manager). Select Edit>Copy Log as Text. This
will copy the entire contents of the logging area of the MDA display as
text to the Windows Clipboard.

Bring up the Write application using ALT-TAB, the Window pull-
down menu in the Program Manager, or clicking on it in the display.
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NOTE

3 Select Edit>Paste in the Write application.

File Edit Find Character Paragraph Document Help

-266 H H H h H
kHz e 103 usec/div

To proceed either load a data file or measure.

Reading parameters from C:\HP53305A\NISETUP.STP

Using default paramters.

Reading from C:\HP53305A\DEMOVFM. PAN

Finished reading from C:\HP53305A\DEMO\FM.PAN

F0=99.99842134100 MHz Pace= 101 N=1024

Waming: Displayed graph may not reflect current setup parameters! Use View Menu to redisplay

data.

Reading parameters from C:\HP53305A\DEMO\FM.STP

Waming: Setup may have changed since graph was displayed!

Computing.

Plotting.

Fo0=99.99942134130 MHz Pace = 101 N=1024

F0=99.99942134130 MHz Pace =101 N=1024

Ymin=-265.57 kHz  Ymax=256.50 kHz  Ymax-Ymin=522.07 kHz

Time= 461.0 usec; Freq Deviation= 251.2 kHz; Phase Deviation Siope= 2.512 psins;
Page 1 fe] ] :

You now have both the graphic results, and the entire log window
neatly pasted in your report.

You may need to modify the font for the logged data. This is easily done
in Write by selecting the text you wish to change and selecting
Character>Reduce/Enlarge Font.

Note also that you can directly edit the logging window in the 563305A
application by positioning the cursor in the logging window and typing or
using basic edit functions from the keyboard. In this way, you can add
annotations to the data, or delete undesired information if desired.

You can copy the entire HP 53305A display using the “Print Screen”
key found in the upper right hand corner of most keyboards. Print
Screen will copy the entire current display to the Windows clipboard.
ALT-Print Screen will copy only the active window to the clipboard.

Sharing Data
Return to the HP 53305A application.

Select File>Save Data

fowdisports.
tde . txt.
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Open the demo directory c:\hp53305a\demo.

Type the filename “temp.txt” and click the OK button.
You have saved the FM data as ASCII text.

Return to the Windows “Write” application.

Select File>Open and click NO to answer the question “Save current
changes?”

Open the demo directory c¢:\hp53305a\demo.

Enter the filename “temp.txt” and click the OK button. Click the No
Conversion button.

Write - TEMP.TXT
Paragraph Document Help

File Edit Find Character

Sequential:
Number of data points:
1025

Phase Analyzer Export Data
0.0000000000E+0
1.0075195860€-6
2.0149902866E-6
3.0225098726E-6
4.0299805733E-6
5.0375001592€E-6
6.0451175159€-6
7.0526857598€E-6
8.0603031165€-6
9.0680177891E-6
1.0075830687E-5
1.1083691788E-5
1.2091651115€-5
1.3099707758E-5
1.4107764400€-5
1.5116064787E-5
1.6124462491E-5
1.7132059320E-5
1.8141503460E-5
1.9150194930E-5
2.0159031919E-5
2.1168016247E-5
2.2177244318E-5
2.3186521503E-5
2.4185896913E-5
2.52054668955E-5
2.6215233447E-5
2.7225145450E-5
2.8235155696E-5
2.9245311453E-5

Page 1

You now have a list of the raw data measured by the HP 53305A
MDA (the “time stamps” — see the Help file for more information).
You could just as easily imported the data into a spread sheet so that
you could perform your own custom analysis of the data.
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You can also save the data to a file using the File>Save Data As
command. Instead of the time stamps, the data is stored in the format
as currently viewed. For instance, if you are viewing a Frequency
Deviation display at the time the data is stored, the data is saved as
Frequency Deviation versus Time values. If you are viewing a Phase
Power Spectral Density display, the data is saved as Frequency
versus Amplitude values.

The HP 53305A makes it easy to share data and graphics with your
word processor and other analysis packages. This completes the

demonstrations.

31



Conclusion

Congratulations! You have completed the HP 53305A Phase Analyzer
demonstration. You have seen the power and flexibility that the

HP 53305A along with the HP 53310A MDA offers for frequency and
phase measurements.

It’s time to take a real test drive! Contact your local HP sales
representative to arrange for an on-site demonstration of the

HP 53310A Option 305 Modulation Domain Analyzer, or call the
Modulation Domain Analyzer Applications Hotline (408) 553-2587,
8AM to 5PM Pacific Time.
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() Prestraty

For more informatiom, call your local HP sales office listed in your telephone directory or an HP
regional office listed below for the location of your nearest sales office.

United States of America:

1800452 4844

Canada:
905 206 4725

Japan:

(81) 426 48 0722
Miami, Florida

(305) 267 4245/4220
Australia:

(008) 131 347 Ext. 2902

Melbourne Caller:
275 2555

New Zealand:
(800) 738 378

Asia Pacific:
Hong Kong
(852) 599 7070

Korea
(2) 769 0800

Taiwan
(2) 717 9680

Singapore
290 6375
India

(11) 690 2311
PRC

(1) 505 3888
Malaysia

(3) 298 6555
Thailand

(2) 254 6720

In Europe, Africa and Middle East, please call your local
HP sales office or representative:

Austria/East Central Europe: Portugal:

(1) 25000-0 (11) 301 73 30

Belgium and Luxembourg: South Africa:

(02) 778 31 11 (011) 806 1000

Denmark: pain:

4599 1000 :00 123 123

(80} (08) 444 20 00

France: i
Switzerland:

(1) 69.82.65.00 (01) 735 7111

feod P

( ) (312)42583 13

I(l)‘fl;xsl‘;l 4 633 United Kingdom:

o1 (0344) 366 666

Israel:

(03) 5380 333

For countries not listed, contact:
Hewlett-Packard
International Sales Europe

Italy:
(02) 92 122 241

Netherlands: Geneva, Switzerland

(020) 547 6669 Tel: +41-22-780-4111
Fax: +41-22-780-4770

Norway:

(22) 73 56 00

Printed in U.S.A.
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Rev 8/94




